Si të azhurnoni versionin PHP në XAMPP (Windows)?

01.06.2020
Artikuj dhe më shumë… 'Si të azhurnoni versionin PHP në XAMPP (Windows)?
0 8 мин.

azhurnoni Windows XP versionin php


Duke qenë vetë një zhvillues i faqes në internet, XAMPP është ndoshta një nga programet kompjuterikë që unë përdor kryesisht në kompjuterin tim Windows. Unë nuk do të hyj në detaje për të shpjeguar pse përdor XAMPP dhe pse duhet të konsideroni gjithashtu përdorimin e tij. Ndërsa më është dashur një kohë për të kuptuar se si të azhurnoj versionin PHP, unë edhe pse do të jetë e dobishme për të shkëmbyer përvojën time dhe për ta bërë punën tuaj më të lehtë dhe duke ju kursyer shumë kohë në këtë detyrë. Ky artikull është i dedikuar për t’ju treguar mundësi të ndryshme se si të azhurnoni versionin PHP në XAMPP Windows dhe të rregulloni çdo problem që mund të vijë së bashku.

Pse duhet të azhurnoni versionin PHP XAMPP?

Ashtu si me çdo softuer tjetër, edhe me PHP gjithashtu rekomandohet të përdorni versionin e fundit. Versioni i ri PHP7 ka shumë përmirësime, në krahasim me PHP5 të vjetër. PHP7 përdor gjysmën e kujtesës dhe performanca e tij është përmirësuar ndjeshëm. Këtu janë disa përfitime të tjera të përdorimit të PHP7:

  • PHP 7 është pothuajse dy herë më i shpejtë se versioni më i ulët i PHP
  • Përdorimi i ulët i kujtesës (deri në 50%)
  • Lehtëson trajtimin e gabimit
  • Mbështetje e sistemeve të Windows 64-bit
  • Operatorët e rinj të anijeve kozmike dhe Null Coalescing
  • Mundëson deklaratat e sakta të tipit
  • Shtoni klasa anonime
  • Lehtëson importet nga i njëjti hapësirë ​​emërore
  • Paraqitja e lidhjes së pavlefshme & Operatori anije kozmike dhe më shumë

Nga ana tjetër, versioni PHP5 nuk do të mbështetet për shumë më gjatë. Për shembull, Joomla 4 do të jetë në përputhje vetëm me serverin që përdorin të paktën versionin PHP7. Këto janë vetëm disa arsye, por ju merrni pikën.

Përditësoni versionin PHP në Windows XAMPP

Nëse jeni duke ekzekutuar një version më të vjetër të XAMPP (3.2.1 ose më të vjetër), ka shumë të ngjarë që akoma jeni duke përdorur PHP5. Këtu janë disa opsione se si të azhurnoni versionin e vjetër PHP5 në PHP7.

  1. Shkarkoni versioni i fundit i PHP që është në përputhje me Windows-in tuaj (x86 ose x64)

  2. Ekstraktoni skedarët në një dosje të quajtur php

  3. Shkoni te drejtoria juaj e instalimit XAMPP dhe riemëroni dosjen e vjetër të php (diçka si php_5)

  4. Kopjoni dosjen php të nxjerrë së fundmi në dosjen tuaj të instalimit XAMPP

  5. Hapni Panelin e Kontrollit XAMPP dhe konfiguroni Apache

  6. Klikoni në butonin Konfiguro ngjitur me modulin Apache dhe zgjidhni Apache (httpd-xampp.conf)

    azhurnoni php windows xampp apache httpd

  7. Zëvendësoni të gjithë php5 me tekstin php7 dhe ruajeni skedarin

  8. Rinisni serverin Apache!

Po sikur serveri Apache të mos fillojë? Ju mund të merrni mesazhin e mëposhtëm të gabimit në panelin tuaj të kontrollit XAMPP:

[Apache] Ndryshimi i statusit u zbulua: ekzekutimi

[Apache] Ndryshimi i statusit u zbulua: u ndal

[Apache] Gabim: Apache mbyllur papritur.

[Apache] Kjo mund të jetë për shkak të një porti të bllokuar, varësi të munguara,

[Apache] privilegje të pahijshme, një përplasje ose mbyllje nga një metodë tjetër.

[Apache] Shtypni butonin Shkrime për të parë regjistrat e gabimeve dhe kontrolloni

[Apache] Viewer i Ngjarjeve në Windows për më shumë të dhëna

[Apache] Nëse keni nevojë për më shumë ndihmë, kopjoni dhe postojeni këtë

[Apache] gjithë dritarja e log në forume

Nëse po, ju lutemi bëni si vijon:

  1. Në panelin e kontrollit XAMPP klikoni në butonin Konfiguro ngjitur me modulin Apache

  2. Zgjidhni Apache (httpd.conf)

    xampp edit apache httpd konf

  3. Gjeni dhe zëvendësoni rreshtat e mëposhtëm:

    Dëgjo 80

    Dëgjo 8080

    Emri i serverit localhost: 80

    Emri i serverit localhost: 8080

  4. Ruani dhe mbyllni skedarin httpd.conf

  5. Redaktoni skedarin httpd-ssl.conf duke klikuar në Apache (http-ssl.conf)

    xampp edit apche httpd ssl konf

  6. Gjeni dhe zëvendësoni rreshtat e mëposhtëm:

    Dëgjo 443

    Dëgjo 4443

    Emri i serverit www.example.com:443

    Emri i serverit www.example.com:4443

  7. Ruani dhe mbyllni skedarin httpd-ssl.conf

  8. Rinisni serverin Apache

Nëse keni bërë gjithçka siç duhet, serveri Apache duhet të fillojë.

Në këtë pikë, një gabim tjetër mund t’ju ndalojë të përdorni serverin XAMPP Apache:

Mungon problemi i DLL me XAMPP

gabim api ms win crt runtime l1 1 0 dll

Programi nuk mund të fillojë sepse api-ms-win-crt-runtime-l1-1-0.dll mungon nga kompjuteri juaj. Provoni të instaloni përsëri programin për të zgjidhur këtë problem.

Ky gabim është për shkak të softuerit të vjetëruar të Microsoft Visual C ++. Gabimi mund të vazhdojë të ekzistojë, edhe pse mund ta keni të instaluar këtë softuer në kompjuterin tuaj.

Ja çfarë mund të bësh:

  1. Shkarko versioni i fundit i Microsoft Visual C++

  2. Ininstaloni versionin e vjetër nga kompjuteri juaj: Filloni > Paneli i kontrollit > Programet ininstaloni një program

  3. Rinisni kompjuterin tuaj

  4. Instaloni versionin e ri që keni shkarkuar së fundmi

  5. Rinisni përsëri kompjuterin tuaj

  6. Nisni panelin e kontrollit XAMPP dhe filloni serverin Apache – gabimi .dll nuk duhet të shfaqet më

Instaloni XAMPP 3.2.2

Nëse asnjë nga metodat e mësipërme nuk funksionon, unë sugjeroj të instaloni versionin e fundit të XAMPP. Versioni i fundit i XAMPP (3.2.2) vjen me PHP7 të përfshirë, kështu që nuk do të duhet të rrëmuani me të gjitha problemet e mësipërme. Por kini kujdes, të mos i mbivendosni skedarët tuaj të vjetër, sepse mund të humbni të gjitha projektet, skedarët dhe bazat e të dhënave. Këtu është një udhëzues i thjeshtë për t’u ndjekur hap pas hapi se si të instaloni XAMPP të ri dhe transferoni projektet tuaja gjatë:

  1. Shkoni te AppacheFrineds.org dhe Shkarko versionin që ju nevojitet

    shkarkoni versionin e fundit xampp

  2. Drejtoni instalimin dhe zgjidhni një dosje tjetër destinacioni për të – nëse versioni juaj i vjetër XAMPP është i instaluar në C: / xampp / dosje, instaloni versionin e ri në C: / newxampp /

  3. Pas instalimit të suksesshëm transferoni C: / xampp / htdocs / dosjen në C: / newxampp / htdocs / – kjo do t’i transferojë të gjithë skedarët e projektit tuaj në instalimin e ri

  4. Gjithashtu transferoni C: / xampp / mysql / të dhënat / në C: / xampp / mysql / të dhëna / – kjo do të transferojë të gjithë informacionin e bazës së të dhënave në instalimin e ri

  5. Hapni Panelin e ri të Kontrollit XAMPP v3.2.2 – dhe filloni Apache dhe MySQL

  6. Tani kontrolloni versionin php http: //localhost/phpinfo.php – ky skedar PHP duhet të përmbajë rreshtin e mëposhtëm:

    <?phpinfo (); ?>

    php info versioni 7 2 6

  7. Filloni të përdorni fuqinë e PHP7!

Duke e mbështetur atë

Unë me të vërtetë shpresoj se ky artikull ju ka ndihmuar. Nëse akoma keni vështirësi, ju lutemi na tregoni në komente dhe do të përpiqeni t’i përgjigjeni pyetjeve tuaja dhe të gjeni një zgjidhje për problemin tuaj. Kodim i lumtur!

Jeffrey Wilson Administrator
Sorry! The Author has not filled his profile.
follow me
    Оцените статью
    Понравилась статья?
    Комментарии (0)
    Комментариев нет, будьте первым кто его оставит

    Комментарии закрыты.

    Adblock
    detector